De ondersteuning van verouderde software versies houdt een keer op. Dat is bij Joomla niet anders. Recente verouderde versies kunnen zonder veel problemen geupdated worden naar nieuwere versies.

Maar bij flink verouderde versies is een migratie-traject nodig.

Joomla 2.5

Om van Joomla 2.5 naar Joomla 3.x over te stappen is een update nodig. Joomla 1.6 en 1.7 zijn via Joomla 2.5.28 naar Joomla 3.x te updaten. Soms zijn er kleine aanpassingen nodig, met name aan verouderde extensies en template aanpassingen. Joomla 2.5.28 is de laatste versie in de Joomla 2.5 reeks. Deze versie wordt sinds 31 december 2014 niet meer ondersteund met (veiligheids) patches.

Joomla 1.5

De programmacode en databasestructuur van Joomla 1.5 is dusdanig anders dat die alleen via een migratie naar Joomla 3 te updaten valt. Oudere versies van Joomla blijven meestal lange tijd gewoon werken, mits de hosting partij de server software (PHP) niet naar nieuwere versies bijwerkt. Maar uit veiligheidsoogpunt is het verstandig om juist wel alle software up-to-date te houden. Joomla 1.5.26 is de laatste versie en wordt sinds september 2012 niet meer ondersteund met (veiligheids) patches.

Joomla 1.0

Joomla 1.0 werd in 2005 uitgebracht. Joomla 1.0.15 is de laatste versie en wordt sinds 22 juli 2009 officieel niet meer door Joomla ondersteund.

Uitbreidingen

Behalve de Joomla software worden er op Joomla website vaak uitbreidingen gebruikt. Dergelijke 3rd party extensies zijn soms lastig over te zetten. Of er bestaan geen versies voor nieuwe Joomla versies. db8 kan u ondersteuning bieden bij de migratie naar nieuwere Joomla versies.